Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
The lxml package before 6.1.0 is vulnerable when using iterparse() or ETCompatXMLParser() in their default configuration, which resolves entities. An attacker who can supply untrusted XML input can read local files on the system through external entity expansion. Upgrade to lxml 6.1.0, which makes the safer resolve_entities='internal' setting the default for these parsers. Until then, set resolve_entities explicitly to 'internal' or False.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 7.5 | High | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0032, the 25th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:11 UTC First seen by agentprime
- 31 Oct 2026, 14:11 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-vfmq-68hx-4jfw
- OSV: GHSA-vfmq-68hx-4jfw
- github.com/lxml/lxml/security/advisories/GHSA-vfmq-68hx-4jfw
- nvd.nist.gov/vuln/detail/CVE-2026-41066
- bugs.launchpad.net/lxml/+bug/2146291
- github.com/lxml/lxml
- github.com/lxml/lxml/releases/tag/lxml-6.1.0
- github.com/pypa/advisory-database/tree/main/vulns/lxml/PYSEC-2026-87.yaml