Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
The PyPI package aj (Ajenti) is affected in versions before 2.2.13. An unauthenticated attacker could gain access to a server and run arbitrary code on it. Users should upgrade to aj 2.2.13, which contains the fix.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.1 | High | 4.0 | CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0059, the 48th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:07 UTC First seen by agentprime
- 31 Oct 2026, 14:07 UTC Confirmed by OSV