Advisory record · GHSA-vc2v-76pw-4v95

compression vulnerable to Denial of Service via memory leak on premature response close

CVSS 7.5 HighEPSS 0.0048 · 41st percentile

Published by the GitHub Advisory Database at 5 Oct 2026, 23:28 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
compressionnpm<1.8.21.8.2
Identifiers
GHSA-vc2v-76pw-4v95 · CVE-2026-87776
Weakness (CWE)
CWE-401 · CWE-459
Published
5 Oct 2026
Updated
5 Oct 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

The npm package compression, versions before 1.8.2, is vulnerable to a denial of service caused by a memory leak when a client disconnects before a compressed response finishes. The zlib stream for each aborted response is never destroyed, so repeated aborted requests can exhaust memory; the source does not say whether any special access is needed beyond sending requests. Users should upgrade to compression 1.8.2, and the source lists no workarounds.

Written 31 Oct 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
7.5 High 3.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CNA (openjs)
  • CISA KEV Not listed.
  • EPSS 0.0048, the 41st percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 13:34 UTC First seen by agentprime
  2. 31 Oct 2026, 13:34 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.