Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
LangChain Experimental versions before 0.0.52 are vulnerable to arbitrary code execution, because a blocklist in pal_chain/base.py fails to prohibit several Python attributes that can be used to reach dangerous functionality. An attacker who can get Python code run through the affected chain can bypass the earlier CVE-2023-44467 fix and execute arbitrary code. The source does not describe the exact access conditions required. Upgrade langchain-experimental to version 0.0.52 or later.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 9.8 | Critical | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H | GitHub Advisory Database |
- CISA KEV Not listed.
- EPSS 0.0077, the 55th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:07 UTC First seen by agentprime
- 31 Oct 2026, 14:07 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-v8vj-cv27-hjv8
- OSV: GHSA-v8vj-cv27-hjv8
- nvd.nist.gov/vuln/detail/CVE-2024-27444
- github.com/langchain-ai/langchain/commit/de9a6cdf163ed00adaf2e559203ed0a9ca2f1de7
- github.com/langchain-ai/langchain
- github.com/pypa/advisory-database/tree/main/vulns/langchain-experimental/PYSEC-2026-375.yaml
- pypi.org/project/langchain-experimental