Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Netty's io.netty:netty-codec-xml package, versions from 4.2.0.Final before 4.2.16.Final and from 4.1.0.Final before 4.1.136.Final, is affected. An unauthenticated remote attacker who can reach a server using XmlFrameDecoder can send a crafted XML stream of repeated closing-tag characters, which makes the decoder rescan its buffer repeatedly and can hang the event loop thread through CPU exhaustion. Upgrade to 4.2.16.Final or 4.1.136.Final.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 7.5 | High | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0079, the 56th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:16 UTC First seen by agentprime
- 31 Oct 2026, 14:16 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-v74w-7mr3-4qg3
- OSV: GHSA-v74w-7mr3-4qg3
- github.com/netty/netty/security/advisories/GHSA-v74w-7mr3-4qg3
- github.com/netty/netty/pull/17063
- github.com/netty/netty/pull/17065
- github.com/netty/netty/commit/5b68c61f37aa4a3045cba624cbea239655c9003b
- github.com/netty/netty/commit/bb2ff68a1fb71cb4b0eb9a9e17b66c52aff680c6
- github.com/netty/netty
- github.com/netty/netty/releases/tag/netty-4.1.136.Final
- github.com/netty/netty/releases/tag/netty-4.2.16.Final