Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
The ckeditor5 and @ckeditor/ckeditor5-engine npm packages, versions from 29.0.0 up to but not including 47.7.4, and from 48.0.0 up to but not including 48.5.1, contain a cross-site scripting flaw in the CKEditor 5 engine. It is triggered by inserting specially crafted markup, and only when General HTML Support is enabled and configured to allow the affected HTML content; the source says JavaScript could then run in a browser context isolated from the embedding application's origin. Upgrade to version 47.7.4 (LTS) or 48.5.1 or later.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 3.1 | Low | 3.1 | CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0025, the 16th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 27 Oct 2026, 19:33 UTC Confirmed by the CVE List
- 27 Oct 2026, 20:17 UTC Confirmed by NVD
- 31 Oct 2026, 13:33 UTC First seen by agentprime
- 31 Oct 2026, 13:33 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-v6mg-96c6-gmpq
- OSV: GHSA-v6mg-96c6-gmpq
- github.com/ckeditor/ckeditor5/security/advisories/GHSA-v6mg-96c6-gmpq
- github.com/ckeditor/ckeditor5/commit/4d9c5bb34f63cd956d15ccafbe584e14280c86a0
- github.com/ckeditor/ckeditor5/commit/a750e38635db6a18c5b11599c09f4fd702850423
- github.com/ckeditor/ckeditor5
- github.com/ckeditor/ckeditor5/releases/tag/v47.7.4
- github.com/ckeditor/ckeditor5/releases/tag/v48.5.1