Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
@simple-git/argv-parser versions before 2.0.1 do not treat the VISUAL environment variable as an unsafe editor setting, so the default guard allows it. An attacker who can influence environment values that an application passes to Git could cause Git to run an attacker-chosen program when an editor opens, such as during commit --amend. Upgrade to version 2.0.1 or later.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 9.2 | Critical | 4.0 | CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0035, the 29th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 13:34 UTC First seen by agentprime
- 31 Oct 2026, 13:34 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-v5rq-49vh-5v5c
- OSV: GHSA-v5rq-49vh-5v5c
- github.com/steveukx/git-js/security/advisories/GHSA-v5rq-49vh-5v5c
- nvd.nist.gov/vuln/detail/CVE-2026-102829
- github.com/steveukx/git-js/pull/1201
- github.com/steveukx/git-js/commit/68874c239f0c7a87f4a68c3d2c4a0d7c75bb27f4
- github.com/steveukx/git-js
- github.com/steveukx/git-js/releases/tag/@simple-git/[email protected]