Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Payload versions below 3.90.0, and 4.0.0-canary versions from 4.0.0-canary.0 up to (not including) 4.0.0-canary.34, are affected. An unauthenticated attacker who knows a user's email address or username can trigger the account lockout mechanism on an auth-enabled collection that uses local authentication, preventing that user from signing in. Upgrade the payload npm package to 3.90.0 or 4.0.0-canary.34 or later, where password resets clear the lockout state and the forgot-password flow enforces a minimum interval between reset emails.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 6.9 | Medium | 4.0 | CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0037, the 30th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 13:33 UTC First seen by agentprime
- 31 Oct 2026, 13:33 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-v5gf-vpjc-pc7w
- OSV: GHSA-v5gf-vpjc-pc7w
- github.com/payloadcms/payload/security/advisories/GHSA-v5gf-vpjc-pc7w
- nvd.nist.gov/vuln/detail/CVE-2026-105866
- github.com/payloadcms/payload/commit/1c46204a73a0a9f988a80c52690eee5a4ada3cf1
- github.com/payloadcms/payload
- github.com/payloadcms/payload/releases/tag/v3.90.0