Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Affected: github.com/dunglas/frankenphp versions before 1.12.5, when PHP's session extension is loaded as a shared module rather than statically compiled in (for example, RPM and Debian packages). In worker mode under concurrent load, a request can receive another client's session ID or a stale one from a prior request, enabling cross-user session exposure and hijacking. Upgrade to 1.12.5. Statically linked builds, such as the official binaries and Docker images, are not affected.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 7.7 | High | 3.1 | CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:L | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0029, the 21st percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:11 UTC First seen by agentprime
- 31 Oct 2026, 14:11 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-v3ph-cgqh-r8p5
- OSV: GHSA-v3ph-cgqh-r8p5
- github.com/php/frankenphp/security/advisories/GHSA-v3ph-cgqh-r8p5
- nvd.nist.gov/vuln/detail/CVE-2026-82416
- github.com/php/frankenphp/pull/2523
- github.com/php/frankenphp/commit/be24d82531675f90862b8cde1e9fc7e9ee855aa5
- github.com/php/frankenphp
- github.com/php/frankenphp/releases/tag/caddy/v1.12.5