Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Apache HttpComponents Core httpcore5-h2 versions before 5.4.3 and from 5.5-alpha1 up to but not including 5.5-beta2 are vulnerable. A remote attacker can send oversized compressed HTTP/2 header blocks before the SETTINGS acknowledgement, which prevents the configured header list size limit from applying and can exhaust memory, causing a denial of service. Upgrade to version 5.4.3 or 5.5-beta2.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 7.5 | High | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H | GitHub Advisory Database |
- CISA KEV Not listed.
- EPSS 0.0087, the 59th percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:16 UTC First seen by agentprime
- 31 Oct 2026, 14:16 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-v3jc-474w-2wm6
- OSV: GHSA-v3jc-474w-2wm6
- nvd.nist.gov/vuln/detail/CVE-2026-54428
- github.com/apache/httpcomponents-core/commit/1ea1239bbbe3442a8382a87279c0a8119a7e358e
- github.com/apache/httpcomponents-core/commit/cc30ee058a7b10cbf4ad3dd6270ab6d1f6a74c49
- github.com/apache/httpcomponents-core
- lists.apache.org/thread/5zjp8vczvxq19pw2rvhs21q446bhl0sd
- www.openwall.com/lists/oss-security/2026/07/01/3