Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Formie (Packagist verbb/formie) versions below 2.2.23 and from 3.0.0 up to 3.1.31 are affected. An authenticated user who lacks the proper form integration permissions can call the form-settings integration action, which applies attacker-supplied settings such as the API URL to a configured integration, causing the server to send stored API keys or OAuth tokens to an attacker-controlled host and return the response. Upgrade to 3.1.31 (Craft 5) or 2.2.23 (Craft 4); the source notes that restricting front-end registration and CP access only reduces risk until the upgrade is applied.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.5 | High | 3.1 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0051, the 43rd percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 13:54 UTC First seen by agentprime
- 31 Oct 2026, 13:54 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-v3f3-cmj4-cvj9
- OSV: GHSA-v3f3-cmj4-cvj9
- github.com/verbb/formie/security/advisories/GHSA-v3f3-cmj4-cvj9
- github.com/verbb/formie/commit/6735fe4ae8f6a2a76930716ad7876b236f7c530d
- github.com/verbb/formie/commit/dde7799dfa7e4d0a11e28754ad8544dba62d5def
- github.com/advisories/GHSA-cvpc-hccg-wmw4
- github.com/verbb/formie
- github.com/verbb/formie/releases/tag/2.2.23
- github.com/verbb/formie/releases/tag/3.1.31