Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Yamcs (org.yamcs:yamcs-core) versions before 5.9.4 are vulnerable to reflected cross-site scripting in the URL of the authorize endpoint. An attacker can get a user to open a crafted link, which runs arbitrary JavaScript in the user's browser and can expose the user's access and refresh tokens, allowing account takeover. Upgrade to yamcs-core 5.9.4 or later.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 6.5 | Medium | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.013, the 70th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:19 UTC First seen by agentprime
- 31 Oct 2026, 14:19 UTC Confirmed by OSV