Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
PhpSpreadsheet versions 3.3.0 up to 3.10.8 and 4.0.0 up to 5.10.0 are affected. The SpreadsheetML XML reader can be tricked by a specially encoded file into skipping its check for XML declarations. An attacker who can get an application to process such a file can cause denial of service through entity expansion on all PHP versions, and can read local files or make server-side requests on PHP below 8.0 or when LIBXML_NOENT is used. Upgrade to 3.10.8 or 5.10.0, which contain fixes.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.8 | High | 4.0 | CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:H/SC:L/SI:N/SA:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0046, the 40th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 13:53 UTC First seen by agentprime
- 31 Oct 2026, 13:53 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-rxj4-h86g-25gc
- OSV: GHSA-rxj4-h86g-25gc
- github.com/PHPOffice/PhpSpreadsheet/security/advisories/GHSA-rxj4-h86g-25gc
- nvd.nist.gov/vuln/detail/CVE-2026-108357
- github.com/PHPOffice/PhpSpreadsheet/commit/89f455c133e1a7e2d4abfadc43ce29eb7450d781
- github.com/PHPOffice/PhpSpreadsheet/commit/980b5c294493856f1a25754f1e8a1d2185b93738
- github.com/PHPOffice/PhpSpreadsheet
- github.com/PHPOffice/PhpSpreadsheet/releases/tag/3.10.8
- github.com/PHPOffice/PhpSpreadsheet/releases/tag/5.10.0