Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
FastAPI Guard versions 3.0.1 up to but not including 3.0.2 are affected. The length limits added to the regular expressions meant to block ReDoS fail to stop inputs longer than those limits, so many of its detection patterns can be bypassed, potentially allowing XSS and SQL injection. Upgrade to fastapi-guard 3.0.2.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 7.8 | High | 4.0 | CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:H/SC:N/SI:N/SA:N/E:P | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0087, the 58th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:34 UTC First seen by agentprime
- 31 Oct 2026, 14:34 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-rrf6-pxg8-684g
- OSV: GHSA-rrf6-pxg8-684g
- github.com/rennf93/fastapi-guard/security/advisories/GHSA-rrf6-pxg8-684g
- nvd.nist.gov/vuln/detail/CVE-2025-54365
- github.com/rennf93/fastapi-guard/commit/0829292c322d33dc14ab00c5451c5c138148035a
- github.com/rennf93/fastapi-guard/commit/d9d50e8130b7b434cdc1b001b8cfd03a06729f7f
- github.com/rennf93/fastapi-guard