Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
The Go module github.com/containerd/containerd/v2 is vulnerable in versions from 2.1.0 before 2.1.9, from 2.2.0 before 2.2.5, and from 2.3.0 before 2.3.2. The CRI plugin restores a container log file from a checkpoint image without validating that it is a symlink, so an attacker who can supply a checkpoint image could read arbitrary files on the host through kubectl logs. Upgrade to version 2.1.9, 2.2.5, or 2.3.2, depending on your release line. Until then, use only trusted images and checkpoints.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.2 | High | 4.0 | CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0017, the 6th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:14 UTC First seen by agentprime
- 31 Oct 2026, 14:14 UTC Confirmed by OSV