Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Apache Struts (org.apache.struts:struts2-core) versions from 2.0.0 through 6.7.4 and from 7.0.0 through 7.0.3 are affected by a denial of service flaw in multipart request processing, where files are leaked and can exhaust disk space. The source does not describe what level of access an attacker needs, but the impact is disk exhaustion on the server. Upgrade to 6.8.0 or 7.1.1, which fix the issue.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.2 | High | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H | GitHub Advisory Database |
- CISA KEV Not listed.
- EPSS 0.0059, the 48th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 15:09 UTC First seen by agentprime
- 31 Oct 2026, 15:09 UTC Confirmed by OSV