Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
The undici npm package is vulnerable in versions from 6.7.0 before 6.28.1, from 7.0.0 before 7.29.1, and from 8.0.0 before 8.10.2. When a server's handshake response includes a WebSocket subprotocol the client never requested, undici throws an uncaught TypeError that terminates the Node.js process. An attacker who controls or compromises a server the application connects to, or who can intercept a plaintext ws:// connection, can cause a denial of service without authentication. Upgrade to undici 6.28.1, 7.29.1, or 8.10.2; the source says no workaround is available.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 7.5 | High | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H | CNA (openjs) |
- CISA KEV Not listed.
- EPSS 0.0039, the 33rd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 13:34 UTC First seen by agentprime
- 31 Oct 2026, 13:34 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-rfgv-xxqx-mfg5
- OSV: GHSA-rfgv-xxqx-mfg5
- github.com/nodejs/undici/security/advisories/GHSA-rfgv-xxqx-mfg5
- nvd.nist.gov/vuln/detail/CVE-2026-19534
- github.com/nodejs/undici/commit/2af0faf88b906d3127a360c3ac75164c0f95e5a5
- github.com/nodejs/undici/commit/6615e0175e9b635bcd2e3e87a47daa82f6f5b728
- github.com/nodejs/undici/commit/66e12816064cf3068f63bd134748b7fc4e779bad
- cna.openjsf.org/security-advisories.html
- github.com/nodejs/undici
- github.com/nodejs/undici/releases/tag/v6.28.1
- github.com/nodejs/undici/releases/tag/v7.29.1
- github.com/nodejs/undici/releases/tag/v8.10.2