Advisory record · GHSA-r9v2-gg2j-22q5

Payload: Insufficient Access Control in Stripe REST Proxy

CVSS 6.4 MediumEPSS 0.0024 · 15th percentile

Published by the GitHub Advisory Database at 6 Oct 2026, 16:09 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
@payloadcms/plugin-stripenpm<3.90.0 || >=4.0.0-canary.0, <4.0.0-canary.343.90.0, 4.0.0-canary.34
Identifiers
GHSA-r9v2-gg2j-22q5 · CVE-2026-105848
Weakness (CWE)
CWE-749 · CWE-862
Published
6 Oct 2026
Updated
6 Oct 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

Payload's @payloadcms/plugin-stripe package is affected in versions below 3.90.0 and from 4.0.0-canary.0 up to but not including 4.0.0-canary.34. An authenticated user who can reach the optional Stripe REST proxy could perform unintended Stripe operations; deployments without the proxy enabled are not affected. Upgrade to 3.90.0 or 4.0.0-canary.34 or later, or if that is not possible, disable the proxy or restrict it to trusted users and only the Stripe operations they need.

Written 31 Oct 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
6.4 Medium 4.0 CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N CNA (GitHub_M)
  • CISA KEV Not listed.
  • EPSS 0.0024, the 15th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 13:34 UTC First seen by agentprime
  2. 31 Oct 2026, 13:34 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.