Advisory record · GHSA-r854-jrxh-36qx

phpseclib has a variable-time HMAC comparison in SSH2::get_binary_packet() using != instead of hash_equals()

CVSS 3.7 LowEPSS 0.0036 · 30th percentile

Published by the GitHub Advisory Database at 10 Apr 2026, 20:58 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
phpseclib/phpseclibPackagist>=0.1.1, <1.0.28 || >=2.0.0, <2.0.53 || >=3.0.0, <3.0.511.0.28, 2.0.53, 3.0.51
Identifiers
GHSA-r854-jrxh-36qx · CVE-2026-40194 · PKSA-zh4j-by9m-7mz8
Weakness (CWE)
CWE-208
Published
10 Apr 2026
Updated
10 Sept 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

phpseclib versions below 1.0.28, from 2.0.0 below 2.0.53, and from 3.0.0 below 3.0.51 compare SSH2 packet HMACs with PHP's != operator in SSH2::get_binary_packet(), a comparison that can run in variable time. The source describes this as a low-severity, defense-in-depth issue and says that practical network exploitation is prevented by the protocol's disconnect-on-MAC-failure behavior and per-connection keys. Upgrade to phpseclib 1.0.28, 2.0.53, or 3.0.51, which replace the comparison with hash_equals().

Written 31 Oct 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
3.7 Low 3.1 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N CNA (GitHub_M)
  • CISA KEV Not listed.
  • EPSS 0.0036, the 30th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 13:59 UTC First seen by agentprime
  2. 31 Oct 2026, 13:59 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.