Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Jenkins core (Maven org.jenkins-ci.main:jenkins-core) versions before 2.555 are vulnerable, including 2.554 and earlier and LTS 2.541.2 and earlier. Its handling of symbolic links while extracting .tar and .tar.gz archives is unsafe, so a crafted archive can write files to arbitrary locations. An attacker with Item/Configure permission, or control of agent processes, can use this to deploy malicious scripts or plugins on the controller. Upgrade jenkins-core to version 2.555.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.8 | High | 3.1 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H | GitHub Advisory Database |
- CISA KEV Not listed.
- EPSS 0.021, the 81st percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:17 UTC First seen by agentprime
- 31 Oct 2026, 14:17 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-r6qv-frpc-q66c
- OSV: GHSA-r6qv-frpc-q66c
- nvd.nist.gov/vuln/detail/CVE-2026-33001
- github.com/jenkinsci/jenkins/commit/6dc99937605d5bddfeaae43a4cd14c2571e23adc
- github.com/jenkinsci/jenkins
- github.com/jenkinsci/jenkins/releases/tag/jenkins-2.555
- www.jenkins.io/security/advisory/2026-03-18/#SECURITY-3657