Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Cachet versions before 2.5.1 are vulnerable. An authenticated user with any role, including a regular User, can trick the application into reinstalling the instance, which can lead to arbitrary code execution on the server. Upgrade to Cachet 2.5.1 or later; as a workaround, allow only trusted IP addresses to reach the administration dashboard.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.8 | High | 3.1 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.024, the 83rd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:25 UTC First seen by agentprime
- 31 Oct 2026, 14:25 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-r67m-m8c7-jp83
- OSV: GHSA-r67m-m8c7-jp83
- github.com/fiveai/Cachet/security/advisories/GHSA-r67m-m8c7-jp83
- nvd.nist.gov/vuln/detail/CVE-2021-39173
- blog.sonarsource.com/cachet-code-execution-via-laravel-configuration-injection
- github.com/fiveai/Cachet
- github.com/fiveai/Cachet/releases/tag/v2.5.1