Advisory record · GHSA-r5x6-w42p-jhpp

Cilium eBPF filters may be temporarily removed during agent restart

CVSS 6.5 MediumEPSS 0.0073 · 54th percentile

Published by the GitHub Advisory Database at 17 Mar 2023, 18:22 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
github.com/cilium/ciliumGo>=1.13.0, <1.13.11.13.1
Identifiers
GHSA-r5x6-w42p-jhpp · BIT-cilium-2023-27595 · BIT-cilium-operator-2023-27595 · BIT-cilium-proxy-2023-27595 · BIT-hubble-2023-27595 · BIT-hubble-relay-2023-27595 · BIT-hubble-ui-2023-27595 · BIT-hubble-ui-backend-2023-27595 · CVE-2023-27595 · GO-2023-1644
Weakness (CWE)
CWE-755
Published
17 Mar 2023
Updated
10 Sept 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

Cilium (Go module github.com/cilium/cilium) versions 1.13.0 before 1.13.1 are affected. During agent startup there is a short window when Cilium eBPF programs are not attached to the host, so Load Balancing and Network Policy enforcement are absent, which can disrupt new connections or allow a network policy bypass for pods and the host namespace. Upgrade to Cilium 1.13.1 or later; no workarounds are known.

Written 2 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
6.5 Medium 3.1 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:L CNA (GitHub_M)
  • CISA KEV Not listed.
  • EPSS 0.0073, the 54th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:16 UTC First seen by agentprime
  2. 31 Oct 2026, 14:16 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.