Advisory record · GHSA-r5pm-vrc5-3m73

cakephp/queue's Incomplete Comparison in getUniqueId vulnerable to collisions

CVSS 3.7 LowEPSS 0.0046 · 40th percentile

Published by the GitHub Advisory Database at 27 Aug 2026, 17:03 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
cakephp/queuePackagist>=0.1.10, <2.3.12.3.1
Identifiers
GHSA-r5pm-vrc5-3m73 · CVE-2026-54713 · PKSA-tgsp-smx2-wtkc
Weakness (CWE)
CWE-1023
Published
27 Aug 2026
Updated
27 Aug 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

The cakephp/queue package, versions 0.1.10 up to but not including 2.3.1, has a flaw in how it builds unique identifiers for jobs with shouldBeUnique enabled. If user-supplied data is included, a malicious user may be able to create identifier collisions, causing legitimate jobs to be dropped. The source does not say what privileges an attacker needs. Upgrade to version 2.3.1, or disable shouldBeUnique and handle idempotency in application code as a workaround.

Written 31 Oct 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
3.7 Low 3.1 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L CNA (GitHub_M)
  • CISA KEV Not listed.
  • EPSS 0.0046, the 40th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:07 UTC First seen by agentprime
  2. 31 Oct 2026, 14:07 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.