Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Kyverno versions before 1.14.2 are vulnerable to a denial of service caused by improper handling of JMESPath variable substitutions. An attacker who can create or update Kyverno policies can use an invalid JMESPath function in a variable expression, which leads to a nil value causing panics that crash admission controller workers and reports controller pods. Upgrade to Kyverno 1.14.2 or later; the source lists no workaround.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 7.7 | High | 3.1 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:H | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0056, the 46th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:14 UTC First seen by agentprime
- 31 Oct 2026, 14:14 UTC Confirmed by OSV