Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
The jline-builtins Maven package (org.jline:jline-builtins) is vulnerable in versions from 4.0.0 before 4.3.1 and from 3.0.0 before 3.30.15. Its built-in grep command wraps the user's regular expression in ".*" before compiling it, which lets a short pattern such as (a+)+b hang the command thread on non-matching input. An attacker who can run grep through a JLine shell exposed to remote users can cause a denial of service; upgrade to version 4.3.1 or 3.30.15.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 7.5 | High | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0060, the 48th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:16 UTC First seen by agentprime
- 31 Oct 2026, 14:16 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-r2xf-8xr9-62gw
- OSV: GHSA-r2xf-8xr9-62gw
- github.com/jline/jline3/security/advisories/GHSA-r2xf-8xr9-62gw
- github.com/jline/jline3/pull/2012
- github.com/jline/jline3/pull/2018
- github.com/jline/jline3/commit/1d5fc3099e77938b971e197211cad2d4fbb17541
- github.com/jline/jline3/commit/341ee69ccc57b7733c1b40d6993219b64b3206ae
- github.com/jline/jline3
- github.com/jline/jline3/releases/tag/4.3.1
- github.com/jline/jline3/releases/tag/jline-3.30.15