Advisory record · GHSA-qxf4-chvg-4r8r

Potential HTTP request smuggling in Apache Tomcat

CVSS 4.8 MediumEPSS 0.094 · 95th percentile

Published by the GitHub Advisory Database at 28 Feb 2020, 01:10 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
org.apache.tomcat.embed:tomcat-embed-coreMaven<7.0.100 || >=8.0.0, <8.5.51 || >=9.0.0, <9.0.317.0.100, 8.5.51, 9.0.31
org.apache.tomcat:tomcatMaven<7.0.100 || >=8.0.0, <8.5.51 || >=9.0.0, <9.0.317.0.100, 8.5.51, 9.0.31
Identifiers
GHSA-qxf4-chvg-4r8r · BIT-tomcat-2020-1935 · CVE-2020-1935
Weakness (CWE)
CWE-444
Published
28 Feb 2020
Updated
7 Aug 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

Apache Tomcat versions 7.0.0 to 7.0.99, 8.5.0 to 8.5.50, and 9.0.0.M1 to 9.0.30 (packages tomcat-embed-core and tomcat) parse some invalid HTTP headers as valid due to how end-of-line is handled. An attacker could exploit this to smuggle requests, but only when Tomcat sits behind a reverse proxy that mishandles the invalid Transfer-Encoding header in a specific way, which the source considers unlikely. Upgrade to 7.0.100, 8.5.51, 9.0.31 or later.

Written 2 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
4.8 Medium 3.1 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N GitHub Advisory Database
  • CISA KEV Not listed.
  • EPSS 0.094, the 95th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:19 UTC First seen by agentprime
  2. 31 Oct 2026, 14:19 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.