Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Mailpit versions before 1.30.0 are vulnerable to path traversal in the mailpit dump --http sub-command. A malicious HTTP server posing as a Mailpit instance can supply message IDs containing ".." segments, causing the tool to write attacker-controlled content to arbitrary locations the running user can write to. An attacker needs the victim to run mailpit dump against the attacker's server, which could happen through a typosquatted or phishing-linked URL. Upgrade to Mailpit 1.30.0 or later. The source gives no workaround beyond upgrading.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 5.9 | Medium | 3.1 | CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:H/A:L | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0039, the 33rd percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:46 UTC First seen by agentprime
- 31 Oct 2026, 14:46 UTC Confirmed by OSV