Advisory record · GHSA-qrxm-fqhp-jwvm

undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation

CVSS 7.5 HighEPSS 0.0019 · 8th percentile

Published by the GitHub Advisory Database at 27 Oct 2026, 19:02 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
undicinpm>=4.2.1, <6.29.1 || >=7.0.0, <7.30.1 || >=8.0.0, <8.12.26.29.1, 7.30.1, 8.12.2
Identifiers
GHSA-qrxm-fqhp-jwvm · CVE-2026-87018
Weakness (CWE)
CWE-248 · CWE-617
Published
27 Oct 2026
Updated
27 Oct 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

Affected: the undici npm package, versions from 4.2.1 up to but not including 6.29.1, from 7.0.0 up to but not including 7.30.1, and from 8.0.0 up to but not including 8.12.2. A malicious or compromised HTTPS server that the client connects to can trigger a TLS 1.2 renegotiation presenting a certificate that does not match the requested host, which makes the Node.js client process crash. Upgrade to undici 6.29.1, 7.30.1, or 8.12.2. Until then, the source suggests restricting connections to TLS 1.3, where renegotiation is not possible.

Written 31 Oct 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
7.5 High 3.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CNA (openjs)
  • CISA KEV Not listed.
  • EPSS 0.0019, the 8th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 13:33 UTC First seen by agentprime
  2. 31 Oct 2026, 13:33 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.