Advisory record · GHSA-qq8j-7v2v-3rwp

undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake

CVSS 7.5 HighEPSS 0.0028 · 20th percentile

Published by the GitHub Advisory Database at 27 Oct 2026, 16:09 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
undicinpm>=8.11.0, <8.11.28.11.2
Identifiers
GHSA-qq8j-7v2v-3rwp · CVE-2026-109855
Weakness (CWE)
CWE-248 · CWE-754
Published
27 Oct 2026
Updated
27 Oct 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

The undici npm package, specifically its experimental WebSocket client, is vulnerable in versions 8.11.0 and 8.11.1 and is fixed in 8.11.2. A remote server that is not authenticated can crash the Node.js process of any client that opens a WebSocket to it over HTTP/2, by answering the upgrade with a response that fails handshake validation and then closing the connection. To fix this, upgrade to undici 8.11.2, or until then set allowH2 to false or avoid untrusted WebSocket servers.

Written 31 Oct 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
7.5 High 3.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CNA (openjs)
  • CISA KEV Not listed.
  • EPSS 0.0028, the 20th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 13:33 UTC First seen by agentprime
  2. 31 Oct 2026, 13:33 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.