Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
PDM versions before 2.27.0 automatically load plugin paths from a project's local .pdm-plugins directory when the CLI starts, and they process .pth files found there. An attacker who can get a user to run pdm inside a malicious repository checkout, such as a running pdm --version, can execute arbitrary code with that user's privileges. Upgrade to PDM 2.27.0 or later, which is listed as the fixed version.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.4 | High | 4.0 | CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0019, the 8th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 15:02 UTC First seen by agentprime
- 31 Oct 2026, 15:02 UTC Confirmed by OSV