Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
PowSyBl Core's com.powsybl:powsybl-commons package, versions before 6.7.2, has XML external entity (XXE) and server-side request forgery (SSRF) flaws in its XML reader. An attacker who can submit XML to affected methods, such as by importing network files in a multi-tenant application, could read files they lack permission to access, including sensitive system files. Upgrade to powsybl-commons 6.7.2 or later.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 2.7 | Low | 4.0 | CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:U | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0044, the 38th percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 15:10 UTC First seen by agentprime
- 31 Oct 2026, 15:10 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-qpj9-qcwx-8jv2
- OSV: GHSA-qpj9-qcwx-8jv2
- github.com/powsybl/powsybl-core/security/advisories/GHSA-qpj9-qcwx-8jv2
- nvd.nist.gov/vuln/detail/CVE-2025-47293
- github.com/powsybl/powsybl-core/commit/e6c7c4997ae8758b54a2f23ce1a499e25113acdc
- github.com/powsybl/powsybl-core
- github.com/powsybl/powsybl-core/releases/tag/v6.7.2