Advisory record · GHSA-qj2w-mw2r-pv39

RubyGems Deserialization of Untrusted Data vulnerability

CVSS 7.8 HighEPSS 0.029 · 86th percentile

Published by the GitHub Advisory Database at 14 May 2022, 01:01 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
rubygems-updateRubyGems<2.7.62.7.6
org.jruby:jruby-stdlibMaven<9.1.16.09.1.16.0
Identifiers
GHSA-qj2w-mw2r-pv39 · CVE-2018-1000074
Weakness (CWE)
CWE-502
Published
14 May 2022
Updated
12 Mar 2024

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

rubygems-update before 2.7.6 has a deserialization of untrusted data flaw in the owner command that can lead to code execution. A victim must run the gem owner command on a gem containing a specially crafted YAML file. Upgrade rubygems-update to 2.7.6, or jruby-stdlib to 9.1.16.0.

Written 8 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
7.8 High 3.0 CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H GitHub Advisory Database
  • CISA KEV Not listed.
  • EPSS 0.029, the 86th percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 15:13 UTC First seen by agentprime
  2. 31 Oct 2026, 15:13 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.