Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
GHSA-qhwx-74w5-xhxq affects the npm package vm2 in versions >=3.9.6 and <3.11.7, fixed in 3.11.7. On Node.js 24 and newer, when an embedder explicitly allows the node:test builtin in NodeVM, sandboxed code can reach the host node:test module through a doubled prefix and pass attacker-controlled execArgv to run(), which can execute JavaScript in an unrestricted host process. The source says this allows full escape of the sandbox with the host user's permissions, so upgrade vm2 to 3.11.7 or later.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 9.4 | Critical | 4.0 | CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H | CNA (VulnCheck) |
- CISA KEV Not listed.
- EPSS 0.0065, the 51st percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 13:34 UTC First seen by agentprime
- 31 Oct 2026, 13:34 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-qhwx-74w5-xhxq
- OSV: GHSA-qhwx-74w5-xhxq
- github.com/patriksimek/vm2/security/advisories/GHSA-qhwx-74w5-xhxq
- nvd.nist.gov/vuln/detail/CVE-2026-92948
- github.com/patriksimek/vm2/commit/415339f698f0d52d3c5ad358b12b79c8072d5b4b
- github.com/patriksimek/vm2
- github.com/patriksimek/vm2/releases/tag/v3.11.7
- www.vulncheck.com/advisories/vm2-3.9.6-through-3.11.5-sandbox-escape-via-node-test