Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Jetty's jetty-http package (org.eclipse.jetty:jetty-http) versions 7.0.0 up to 12.0.12 are affected. The HttpURI utility class, when used directly by an application, accepts malformed URIs with unvalidated authority sections and may extract a different host than a browser does. An attacker who can supply such a URI could bypass host blocklists, enabling open redirect or server-side request forgery, when combined with a vulnerable browser. Upgrade to version 12.0.12, which fully validates URI authority characters.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 3.7 | Low | 3.1 | CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N | CNA (eclipse) |
- CISA KEV Not listed.
- EPSS 0.0097, the 61st percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:17 UTC First seen by agentprime
- 31 Oct 2026, 14:17 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-qh8g-58pp-2wxh
- OSV: GHSA-qh8g-58pp-2wxh
- github.com/jetty/jetty.project/security/advisories/GHSA-qh8g-58pp-2wxh
- nvd.nist.gov/vuln/detail/CVE-2024-6763
- github.com/jetty/jetty.project/pull/12012
- github.com/jetty/jetty.project
- gitlab.eclipse.org/security/cve-assignement/-/issues/25
- security.netapp.com/advisory/ntap-20250306-0005