Advisory record · GHSA-qg2p-9jwr-mmqf

Django vulnerable to Denial of Service

CVSS 7.5 HighEPSS 0.012 · 67th percentile

Published by the GitHub Advisory Database at 10 Jul 2024, 06:33 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
djangoPyPI>=4.2, <4.2.14 || >=5.0, <5.0.74.2.14, 5.0.7
Identifiers
GHSA-qg2p-9jwr-mmqf · BIT-django-2024-38875 · CVE-2024-38875 · PYSEC-2024-56
Weakness (CWE)
CWE-130 · CWE-770
Published
10 Jul 2024
Updated
10 Sept 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

Django versions 4.2 before 4.2.14 and 5.0 before 5.0.7 are vulnerable to denial of service. The urlize and urlizetrunc functions can be slowed severely by specially crafted input containing a very large number of brackets, and the source does not describe any required access or user action. Upgrade to Django 4.2.14, 5.0.7, or later.

Written 5 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
7.5 High 3.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H GitHub Advisory Database
  • CISA KEV Not listed.
  • EPSS 0.012, the 67th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:35 UTC First seen by agentprime
  2. 31 Oct 2026, 14:35 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.