Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
The vLLM package before 0.32.0 is affected: a pre-tokenized prompt containing a token id equal to the model's vocabulary size (for example 32000 on Llama-2-family models) passes input validation and triggers a CUDA device-side assert at tensor-parallel size 1, crashing the engine. Any client able to send pre-tokenized input can cause this with a single request, leading to denial of service. Upgrade to vLLM 0.32.0, which fixes the issue.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 6.5 | Medium | 3.1 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0031, the 24th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 26 Oct 2026, 17:18 UTC Confirmed by the CVE List
- 26 Oct 2026, 18:17 UTC Confirmed by NVD
- 31 Oct 2026, 14:07 UTC First seen by agentprime
- 31 Oct 2026, 14:07 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-q97c-p368-75c4
- OSV: GHSA-q97c-p368-75c4
- github.com/vllm-project/vllm/security/advisories/GHSA-q97c-p368-75c4
- nvd.nist.gov/vuln/detail/CVE-2026-115916
- github.com/vllm-project/vllm/pull/59491
- github.com/vllm-project/vllm/commit/37cecc8141e2dcba9dd534897a164d4baaf27229
- github.com/vllm-project/vllm
- github.com/vllm-project/vllm/releases/tag/v0.32.0