Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
GHSA-q6cq-mhr2-jmr5 affects the Netty netty-codec-haproxy package, versions from 4.2.0.Final before 4.2.16.Final and from 4.1.0.Final before 4.1.136.Final. A remote attacker who can send crafted bytes to a server using HAProxyMessageDecoder can exhaust the JVM's direct memory, because the decoder keeps buffering inbound data without limit. Upgrade to 4.2.16.Final or 4.1.136.Final, or later.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.7 | High | 4.0 | CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0063, the 50th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:16 UTC First seen by agentprime
- 31 Oct 2026, 14:16 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-q6cq-mhr2-jmr5
- OSV: GHSA-q6cq-mhr2-jmr5
- github.com/netty/netty/security/advisories/GHSA-q6cq-mhr2-jmr5
- nvd.nist.gov/vuln/detail/CVE-2026-55851
- github.com/netty/netty/commit/5b68c61f37aa4a3045cba624cbea239655c9003b
- github.com/netty/netty/commit/bb2ff68a1fb71cb4b0eb9a9e17b66c52aff680c6
- github.com/netty/netty
- github.com/netty/netty/releases/tag/netty-4.1.136.Final
- github.com/netty/netty/releases/tag/netty-4.2.16.Final