Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Netty's netty-codec-http package, versions from 4.2.0.Final before 4.2.16.Final and from 4.1.0 before 4.1.136.Final (per the affected range given), has an unbounded per-connection queue in HttpContentEncoder and its subclass HttpContentCompressor. An attacker who can send HTTP/1.1 pipelined requests faster than the application writes responses can make this queue grow without limit, causing resource exhaustion and denial of service. Upgrade to 4.2.16.Final or 4.1.136.Final.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 6.9 | Medium | 4.0 | CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0061, the 49th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:17 UTC First seen by agentprime
- 31 Oct 2026, 14:17 UTC Confirmed by OSV