Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Netty's netty-codec-http package is affected in versions below 4.1.132.Final and from 4.2.0.Alpha1 up to but not including 4.2.10.Final. Netty stops parsing chunk extension headers at CR/LF bytes inside quoted strings instead of rejecting the request, so a remote attacker can smuggle extra HTTP requests over a connection. Upgrade to 4.1.132.Final or 4.2.10.Final. The source gives no workaround.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 7.5 | High | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0070, the 53rd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:17 UTC First seen by agentprime
- 31 Oct 2026, 14:17 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-pwqr-wmgm-9rr8
- OSV: GHSA-pwqr-wmgm-9rr8
- github.com/netty/netty/security/advisories/GHSA-pwqr-wmgm-9rr8
- nvd.nist.gov/vuln/detail/CVE-2026-33870
- github.com/netty/netty
- w4ke.info/2025/06/18/funky-chunks.html
- w4ke.info/2025/10/29/funky-chunks-2.html
- www.rfc-editor.org/rfc/rfc9110