Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
containerd versions before 1.7.29 and 2.x versions before 2.0.7, 2.1.5 and 2.2.0 create some runtime and metadata directories with overly broad permissions. A local user on the host can access the metadata and content stores, and possibly the contents of Kubernetes local volumes, which could allow privilege escalation. Upgrade to 1.7.29, 2.0.7, 2.1.5 or 2.2.0, matching your release line; the update also corrects permissions on existing directories.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 7.3 | High | 3.1 | CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0017, the 6th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:13 UTC First seen by agentprime
- 31 Oct 2026, 14:13 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-pwhc-rpq9-4c8w
- OSV: GHSA-pwhc-rpq9-4c8w
- github.com/containerd/containerd/security/advisories/GHSA-pwhc-rpq9-4c8w
- nvd.nist.gov/vuln/detail/CVE-2024-25621
- github.com/containerd/containerd/commit/7c59e8e9e970d38061a77b586b23655c352bfec5
- github.com/containerd/containerd
- github.com/containerd/containerd/blob/main/docs/rootless.md