Advisory record · GHSA-pwfv-3cvg-9m4c

org.xwiki.platform:xwiki-platform-oldcore makes Incorrect Use of Privileged APIs with DocumentAuthors

CVSS 9.1 CriticalCriticalEPSS 0.0090 · 59th percentile

Critical, because:

  • CVSS score 9.1: 9.0 or more.

How we decide what’s critical

Published by the GitHub Advisory Database at 12 Apr 2023, 20:36 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
org.xwiki.platform:xwiki-platform-oldcoreMaven>=14.5, <14.10 || >=14.4.1, <14.4.714.10, 14.4.7
Identifiers
GHSA-pwfv-3cvg-9m4c · CVE-2023-29507
Weakness (CWE)
CWE-648
Published
12 Apr 2023
Updated
10 Sept 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

The xwiki-platform-oldcore Maven package, versions 14.5 to before 14.10 and 14.4.1 to before 14.4.7, exposes a Document script API that returns author objects which can be set on a document. An attacker who can run scripts in XWiki can use this to assign arbitrary authors to a document, and subsequent script executions then check rights against that author. Upgrade to version 14.10 or 14.4.7. The source lists no workaround other than upgrading.

Written 2 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
9.1 Critical 3.1 CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H CNA (GitHub_M)
  • CISA KEV Not listed.
  • EPSS 0.0090, the 59th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:18 UTC First seen by agentprime
  2. 31 Oct 2026, 14:18 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.