Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Arcane (Go module github.com/getarcaneapp/arcane/backend/v2) versions before 2.6.0 are affected. A user holding the delegated users:update permission can set the password of any account, including the global administrator's, because the update path performs no check comparing the caller's privileges with the target's. An attacker with that permission could then log in as the administrator and take over the admin account. Upgrade to version 2.6.0 or later.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.8 | High | 3.1 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0037, the 30th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:11 UTC First seen by agentprime
- 31 Oct 2026, 14:11 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-pw5q-rjx4-7f7p
- OSV: GHSA-pw5q-rjx4-7f7p
- github.com/getarcaneapp/arcane/security/advisories/GHSA-pw5q-rjx4-7f7p
- github.com/getarcaneapp/arcane/pull/3426
- github.com/getarcaneapp/arcane/commit/21ea962f86d967dac8ae02a050f6e5f043d10fa1
- github.com/getarcaneapp/arcane
- github.com/getarcaneapp/arcane/releases/tag/backend/v2.6.0