Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Rancher versions >=2.0.0 before 2.4.16 and >=2.5.0 before 2.5.9 are vulnerable. A valid Rancher user with some permissions on a managed cluster can send a crafted API request through the cluster's Kubernetes API proxy, using the Connection header to strip impersonation headers, and read information they should not have access to. Upgrade to Rancher 2.4.16 or 2.5.9; no other mitigation is listed.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.8 | High | 3.1 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H | CNA (suse) |
- CISA KEV Not listed.
- EPSS 0.011, the 64th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:15 UTC First seen by agentprime
- 31 Oct 2026, 14:15 UTC Confirmed by OSV