Advisory record · GHSA-prxr-vjgc-2cq9

Concrete CMS is Vulnerable to Cross-Site Request Forgery

CVSS 7.5 HighEPSS 0.0013 · 2nd percentile

Published by the GitHub Advisory Database at 21 May 2026, 21:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
concrete5/concrete5Packagist<9.5.19.5.1
Identifiers
GHSA-prxr-vjgc-2cq9 · CVE-2026-8428 · PKSA-fqsc-qq8z-j29z
Weakness (CWE)
CWE-352 · CWE-829
Published
21 May 2026
Updated
10 Sept 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

The concrete5/concrete5 Packagist package, versions below 9.5.1, does not verify a CSRF token on the core update action in the dashboard. An attacker could get a logged-in user who is allowed to upgrade the site to visit a page that submits a cross-site POST, triggering a core CMS update to an attacker-specified version, provided a valid update version is present. Upgrade to 9.5.1 or later.

Written 31 Oct 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
7.5 High 4.0 CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N CNA (ConcreteCMS)
  • CISA KEV Not listed.
  • EPSS 0.0013, the 2nd percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:01 UTC First seen by agentprime
  2. 31 Oct 2026, 14:01 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.