Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Tornado versions before 6.5.3 are vulnerable to header injection and reflected cross-site scripting through the `reason` argument of `RequestHandler.set_status` and `tornado.web.HTTPError`. A remote attacker can exploit this only if the application passes attacker-controlled data as `reason`, which can then inject headers or run JavaScript in a victim's browser on the default error page. Upgrade to Tornado 6.5.3 or newer. Until then, avoid passing untrusted data as `reason`, and use `log_message` for custom error text in HTTPError.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 5.4 | Medium | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0024, the 15th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:42 UTC First seen by agentprime
- 31 Oct 2026, 14:42 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-pr2v-jx2c-wg9f
- OSV: GHSA-pr2v-jx2c-wg9f
- github.com/tornadoweb/tornado/security/advisories/GHSA-pr2v-jx2c-wg9f
- nvd.nist.gov/vuln/detail/CVE-2025-67724
- github.com/tornadoweb/tornado/commit/9c163aebeaad9e6e7d28bac1f33580eb00b0e421
- github.com/pypa/advisory-database/tree/main/vulns/tornado/PYSEC-2025-265.yaml
- github.com/tornadoweb/tornado
- github.com/tornadoweb/tornado/releases/tag/v6.5.3