Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
The aiohttp package versions before 3.14.4 are vulnerable when the pure Python HTTP parser is in use, which happens when the AIOHTTP_NO_EXTENSIONS setting is enabled or when no standard wheel is installed. An attacker may be able to smuggle HTTP requests past the application. Upgrade to aiohttp 3.14.4 or later. Alternatively, use the default C parser by not forcing the pure Python one.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 6.3 | Medium | 4.0 | CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:L/SC:N/SI:L/SA:L | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0038, the 32nd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:08 UTC First seen by agentprime
- 31 Oct 2026, 14:08 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-pqxq-w44r-73xw
- OSV: GHSA-pqxq-w44r-73xw
- github.com/aio-libs/aiohttp/security/advisories/GHSA-pqxq-w44r-73xw
- nvd.nist.gov/vuln/detail/CVE-2026-111750
- github.com/aio-libs/aiohttp/commit/9b27347e61454d9f8ca2055f4c67a37dee336e83
- github.com/aio-libs/aiohttp
- github.com/aio-libs/aiohttp/releases/tag/v3.14.4