Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
The Sylius PayPal Plugin (sylius/paypal-plugin) versions before 1.6.1, from 1.7.0 before 1.7.1, and from 2.0.0 before 2.0.1 are affected. If a customer changes item quantities in their cart after starting PayPal Checkout, PayPal is not sent the updated total, so the customer can pay less than the order value, and Sylius marks the order as fully paid. Upgrade to version 1.6.1, 1.7.1, or 2.0.1 or later; the source also describes workarounds that involve overriding several plugin classes, which are documented in the advisory.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 6.5 | Medium | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0050, the 43rd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:04 UTC First seen by agentprime
- 31 Oct 2026, 14:04 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-pqq3-q84h-pj6x
- OSV: GHSA-pqq3-q84h-pj6x
- github.com/Sylius/PayPalPlugin/security/advisories/GHSA-pqq3-q84h-pj6x
- nvd.nist.gov/vuln/detail/CVE-2025-29788
- github.com/Sylius/PayPalPlugin/commit/31e71b0457e5d887a6c19f8cfabb8b16125ec406
- github.com/Sylius/PayPalPlugin/commit/8a81258f965b7860d4bccb52942e4c5b53e6774d
- github.com/Sylius/PayPalPlugin
- github.com/Sylius/PayPalPlugin/releases/tag/v1.6.1
- github.com/Sylius/PayPalPlugin/releases/tag/v1.7.1
- github.com/Sylius/PayPalPlugin/releases/tag/v2.0.1