Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Versions 2.2.0 up to but not including 2.11.14, and 2.12.0 up to but not including 2.12.5, of the nats-server Go module are vulnerable. A remote, unauthenticated attacker with network access to a WebSocket listener can send a crafted WebSocket frame that crashes the whole server process, disconnecting all clients. Upgrade to 2.11.14 or 2.12.5. If you cannot upgrade, restrict network access to the WebSocket port to trusted endpoints. No fix is listed for the unversioned github.com/nats-io/nats-server entry.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 7.5 | High | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0059, the 48th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:14 UTC First seen by agentprime
- 31 Oct 2026, 14:14 UTC Confirmed by OSV