Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
JupyterLab versions 3.3.0 up to 4.5.10 and 4.6.0 up to 4.6.2 are affected. A crafted overrides.json settings file, imported through the Settings Editor or placed in a settings directory that another user can write to, can run code in the context of the affected user, reaching their notebooks, files, and kernels. Upgrade to JupyterLab 4.5.10 or 4.6.2. No workarounds are listed, though restricting write access to shared settings directories reduces the risk.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.6 | High | 4.0 | CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:L/SC:N/SI:N/SA:L | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0075, the 55th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:29 UTC First seen by agentprime
- 31 Oct 2026, 14:29 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-pppj-hq3g-57pj
- OSV: GHSA-pppj-hq3g-57pj
- github.com/jupyterlab/jupyterlab/security/advisories/GHSA-pppj-hq3g-57pj
- github.com/jupyterlab/jupyterlab/pull/19184
- github.com/jupyterlab/jupyterlab/pull/19185
- github.com/jupyterlab/jupyterlab/pull/19186
- github.com/jupyterlab/jupyterlab/commit/be9303f5bcd5308eaeae953c5a3c903046682c2c
- github.com/jupyterlab/jupyterlab/commit/f1beab4a2027af4719d6edc07d52d6cf5a39a432
- github.com/jupyterlab/jupyterlab
- github.com/jupyterlab/jupyterlab/releases/tag/v4.5.10
- github.com/jupyterlab/jupyterlab/releases/tag/v4.6.2