Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
vLLM versions from 0.5.5 before 0.11.1 are vulnerable to a denial of service. An attacker who can send requests to the server can pass multimodal embedding inputs with the correct number of dimensions but a wrong shape, such as an incorrect hidden dimension, crashing the engine. Upgrade to vLLM 0.11.1 or later. As a workaround, restrict access to trusted users with an API key, or set --limit-mm-per-prompt to 0 for non-text modalities, though this leaves the model accepting only text.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.3 | High | 4.0 | CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:H | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0041, the 35th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:29 UTC First seen by agentprime
- 31 Oct 2026, 14:29 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-pmqf-x6x8-p7qw
- OSV: GHSA-pmqf-x6x8-p7qw
- github.com/vllm-project/vllm/security/advisories/GHSA-pmqf-x6x8-p7qw
- nvd.nist.gov/vuln/detail/CVE-2025-62372
- github.com/vllm-project/vllm/pull/27204
- github.com/vllm-project/vllm/pull/6613
- github.com/vllm-project/vllm/commit/58fab50d82838d5014f4a14d991fdb9352c9c84b
- github.com/advisories/GHSA-pmqf-x6x8-p7qw
- github.com/pypa/advisory-database/tree/main/vulns/vllm/PYSEC-2026-2019.yaml
- github.com/vllm-project/vllm
- pypi.org/project/vllm